Unexpected Service Incident.
Incident Report for Ouriginal
Resolved
This incident has been resolved.
Posted Jun 27, 2023 - 12:51 UTC
Investigating
We've run into some issues.

Ouriginal by Turnitin is currently experiencing an unexpected service incident.

During this time, you may find that the similarity score don't change when you manually remove a source from the report.

We invite you to track the progress of this incident while we work to bring the service back to optimum health.
Posted Jun 21, 2023 - 08:07 UTC
This incident affected: Ouriginal Plagiarism Detection Result Interface.