Unexpected Service Incident.
Incident Report for Ouriginal
Resolved
We've fixed it!

Due to an unexpected issue, you may have been unable to review reports in Ouriginal by Turnitin today. We are pleased to advise that service has been restored.

The incident occurred between the following times:
2:40pm GMT+2 to 3:15pm GMT+2

We regret any inconvenience this may have caused if you were impacted by today's incident.
Posted Sep 20, 2023 - 14:14 UTC
Monitoring
We've fixed it!

Due to an unexpected issue, you may have been unable to review reports in Ouriginal by Turnitin today. We are pleased to advise that service has been restored.


We regret any inconvenience this may have caused if you were impacted by today's incident.
Posted Sep 20, 2023 - 13:25 UTC
Investigating
We've run into some issues.

Ouriginal by Turnitin is currently experiencing an unexpected service incident.

During this time, you may find that reports are unavailable.

We invite you to track the progress of this incident while we work to bring the service back to optimum health.
Posted Sep 20, 2023 - 12:57 UTC
This incident affected: Ouriginal Plagiarism Detection Result Interface.